summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-11-12 22:20:41 +0100
committerFelix Fietkau <nbd@nbd.name>2023-12-18 11:42:08 +0100
commit66dfbca262f4e6ebc1b4f94fb1c4482894c26d0c (patch)
treef178dd634b26a332b8fb1edf3221719c804ae44e /toolchain/gdb
parent493f7f5eeec4e97ff9da9cfb23c26d7c273b44c9 (diff)
downloadopenwrt-66dfbca262f4e6ebc1b4f94fb1c4482894c26d0c.tar.gz
openwrt-66dfbca262f4e6ebc1b4f94fb1c4482894c26d0c.tar.bz2
openwrt-66dfbca262f4e6ebc1b4f94fb1c4482894c26d0c.zip
toolchain/gdb: export ZSTD_CFLAGS/LIBS to fix build on non-linux systems
Avoids picking up libs and header files from musl Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 9c0ed520bd..5ad0cd2d8c 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,6 +22,9 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
+export ZSTD_CFLAGS=-I$(STAGING_DIR_HOST)/include
+export ZSTD_LIBS=-L$(STAGING_DIR_HOST)/lib -lzstd
+
HOST_CONFIGURE_VARS += \
acx_cv_cc_gcc_supports_ada=false \
gdb_cv_func_sigsetjmp=yes