summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-02 14:16:20 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-02 15:58:45 +0100
commit7e2c271a8053df940d554cc5e17066033da4fc82 (patch)
tree6c0d95b1862bec9e4d4d2f9059cbbec4e6def0a8 /toolchain
parent23dd6db2ea6d783c16bf10b43c23478b7f26723d (diff)
downloadopenwrt-7e2c271a8053df940d554cc5e17066033da4fc82.tar.gz
openwrt-7e2c271a8053df940d554cc5e17066033da4fc82.tar.bz2
openwrt-7e2c271a8053df940d554cc5e17066033da4fc82.zip
gcc: remove support for libgcj/java
It has been removed in gcc 7 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in8
-rw-r--r--toolchain/gcc/common.mk7
2 files changed, 2 insertions, 13 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index ea33ac29c1..a54c8d12d3 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -54,14 +54,6 @@ config SJLJ_EXCEPTIONS
frame unwinding exceptions handling routines. Warning: increases
code size and runtime memory usage.
-config INSTALL_LIBGCJ
- bool
- prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
- default n
- help
- Build/install java compiler and GNU classpath ?
-
-
config INSTALL_GFORTRAN
bool
prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index d7e205a011..f22b8adc2a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -74,14 +74,11 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.gcc_$(GCC_VARIANT)_installed
SEP:=,
-TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
+TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
TAR_OPTIONS += \
--exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
-
-ifndef CONFIG_INSTALL_LIBGCJ
- TAR_OPTIONS += --exclude=libjava
-endif
+ --exclude=libjava
export libgcc_cv_fixed_point=no
ifdef CONFIG_USE_UCLIBC