summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorYorkie Liu <yorkiefixer@gmail.com>2019-11-19 13:41:10 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 01:06:59 +0100
commit84b74bcb0d962dc192dc6c3f0ada3e0eba6fb593 (patch)
treee365a5b9ce7b2754a6170a13e7e16cf53709ffe5 /toolchain
parent66ba44c9ec64e4b379008fa294e7b54302202007 (diff)
downloadopenwrt-84b74bcb0d962dc192dc6c3f0ada3e0eba6fb593.tar.gz
openwrt-84b74bcb0d962dc192dc6c3f0ada3e0eba6fb593.tar.bz2
openwrt-84b74bcb0d962dc192dc6c3f0ada3e0eba6fb593.zip
toolchain/gcc: correct the check expr for newer clang
This fixes gcc build error within clang 11.0, it tweaks the version string from LLVM to clang. Signed-off-by: Yorkie Liu <yorkiefixer@gmail.com> (cherry picked from commit 65a561fd0919eafff2363ae8324db64be2a57f77)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index fb60e57c73..0b7e5f468e 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -96,7 +96,7 @@ endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
- $(if $(shell gcc --version 2>&1 | grep LLVM), \
+ $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
CFLAGS="-O2 -fbracket-depth=512 -pipe" \
CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
) \