summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-24 11:02:30 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-24 11:08:44 +0200
commitcb352a7c4cf74fb9c0067bd62517fc59763ebc5a (patch)
tree5bc52ff8c8724f2ee9276a241d17b629d2027767 /toolchain
parent609707cbe7cfce2038cf54a8deb6c341a06df1d8 (diff)
downloadopenwrt-cb352a7c4cf74fb9c0067bd62517fc59763ebc5a.tar.gz
openwrt-cb352a7c4cf74fb9c0067bd62517fc59763ebc5a.tar.bz2
openwrt-cb352a7c4cf74fb9c0067bd62517fc59763ebc5a.zip
build: drop buildbot toolchain rebuild check when not using git
The check cleans and rebuilds the toolchain if it changed on update. When building from a source tarball, it is reasonable to expect that there will be no updates, so no rebuild check is necessary Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 409955c23a..e4631bc7bf 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -70,6 +70,7 @@ endif
endif
ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
$(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
cmp -s $(TMP_DIR)/.ver_check $@ || { \
@@ -80,6 +81,7 @@ ifdef CONFIG_BUILDBOT
$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
endif
+endif
# prerequisites for the individual targets
$(curdir)/ := .config prereq