summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-22 10:17:33 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-28 18:29:10 +0200
commitfac1f38d7559230eddbbab996c32b12b314fae15 (patch)
tree0c3c36edba4c1eac6bb3a2e5bf758d1e1a3b2f37 /toolchain
parentf0adf253fdcf78ce005dad9652b405a4ad2726e6 (diff)
downloadopenwrt-fac1f38d7559230eddbbab996c32b12b314fae15.tar.gz
openwrt-fac1f38d7559230eddbbab996c32b12b314fae15.tar.bz2
openwrt-fac1f38d7559230eddbbab996c32b12b314fae15.zip
toolchain: bump GCC 12 to 12.2.0
Refreshed patches: - 910-mbsd_multi.patch - 970-macos_arm64-building-fix.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/12.2.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/12.1.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/010-documentation.patch (renamed from toolchain/gcc/patches/12.1.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/12.1.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/12.1.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/12.1.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/12.1.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/12.1.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/12.1.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/12.1.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/12.1.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/12.1.0/870-ppc_no_crtsavres.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/12.1.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/12.1.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/12.1.0/910-mbsd_multi.patch)2
-rw-r--r--toolchain/gcc/patches/12.2.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/12.1.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/12.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
-rw-r--r--toolchain/gcc/patches/12.2.0/970-macos_arm64-building-fix.patch (renamed from toolchain/gcc/patches/12.1.0/970-macos_arm64-building-fix.patch)10
19 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 1caa51a291..a909979cf6 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -14,5 +14,5 @@ config GCC_VERSION
string
default "8.4.0" if GCC_VERSION_8
default "10.3.0" if GCC_VERSION_10
- default "12.1.0" if GCC_VERSION_12
+ default "12.2.0" if GCC_VERSION_12
default "11.3.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 926418f4a7..f116af7e1a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -40,8 +40,8 @@ ifeq ($(PKG_VERSION),11.3.0)
PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
endif
-ifeq ($(PKG_VERSION),12.1.0)
- PKG_HASH:=62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b
+ifeq ($(PKG_VERSION),12.2.0)
+ PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
endif
PATCH_DIR=../patches/$(GCC_VERSION)
diff --git a/toolchain/gcc/patches/12.1.0/002-case_insensitive.patch b/toolchain/gcc/patches/12.2.0/002-case_insensitive.patch
index 409497e5a3..409497e5a3 100644
--- a/toolchain/gcc/patches/12.1.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/12.2.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/12.1.0/010-documentation.patch b/toolchain/gcc/patches/12.2.0/010-documentation.patch
index 39ee48ed67..39ee48ed67 100644
--- a/toolchain/gcc/patches/12.1.0/010-documentation.patch
+++ b/toolchain/gcc/patches/12.2.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/12.1.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/12.2.0/110-Fix-MIPS-PR-84790.patch
index 856fd6a46c..856fd6a46c 100644
--- a/toolchain/gcc/patches/12.1.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/12.2.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/12.1.0/230-musl_libssp.patch b/toolchain/gcc/patches/12.2.0/230-musl_libssp.patch
index 3ce5e49587..3ce5e49587 100644
--- a/toolchain/gcc/patches/12.1.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/12.2.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/12.1.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/12.2.0/300-mips_Os_cpu_rtx_cost_model.patch
index 1d223f2a0f..1d223f2a0f 100644
--- a/toolchain/gcc/patches/12.1.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/12.2.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/12.1.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/12.2.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/12.1.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/12.2.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/12.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/12.2.0/820-libgcc_pic.patch
index 525a95b565..525a95b565 100644
--- a/toolchain/gcc/patches/12.1.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/12.2.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/12.1.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/12.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
index e3cb616c4e..e3cb616c4e 100644
--- a/toolchain/gcc/patches/12.1.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/12.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/12.1.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/12.2.0/850-use_shared_libgcc.patch
index 7be30f3283..7be30f3283 100644
--- a/toolchain/gcc/patches/12.1.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/12.2.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/12.1.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/12.2.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/12.1.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/12.2.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/12.1.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/12.2.0/870-ppc_no_crtsavres.patch
index e51079dc13..e51079dc13 100644
--- a/toolchain/gcc/patches/12.1.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/12.2.0/870-ppc_no_crtsavres.patch
diff --git a/toolchain/gcc/patches/12.1.0/881-no_tm_section.patch b/toolchain/gcc/patches/12.2.0/881-no_tm_section.patch
index 2029910fd0..2029910fd0 100644
--- a/toolchain/gcc/patches/12.1.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/12.2.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/12.1.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/12.2.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/12.1.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/12.2.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/12.1.0/910-mbsd_multi.patch b/toolchain/gcc/patches/12.2.0/910-mbsd_multi.patch
index 37aba93b94..4033c5b23b 100644
--- a/toolchain/gcc/patches/12.1.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/12.2.0/910-mbsd_multi.patch
@@ -134,7 +134,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
@opindex Wno-stack-protector
--- a/gcc/opts.cc
+++ b/gcc/opts.cc
-@@ -2658,6 +2658,9 @@ common_handle_option (struct gcc_options
+@@ -2692,6 +2692,9 @@ common_handle_option (struct gcc_options
add_comma_separated_to_vector (&opts->x_flag_ignored_attributes, arg);
break;
diff --git a/toolchain/gcc/patches/12.1.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/12.2.0/920-specs_nonfatal_getenv.patch
index 0f7d40b244..0f7d40b244 100644
--- a/toolchain/gcc/patches/12.1.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/12.2.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/12.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/12.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index b1d7576328..b1d7576328 100644
--- a/toolchain/gcc/patches/12.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/12.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
diff --git a/toolchain/gcc/patches/12.1.0/970-macos_arm64-building-fix.patch b/toolchain/gcc/patches/12.2.0/970-macos_arm64-building-fix.patch
index d164d70e88..86fa68e1b1 100644
--- a/toolchain/gcc/patches/12.1.0/970-macos_arm64-building-fix.patch
+++ b/toolchain/gcc/patches/12.2.0/970-macos_arm64-building-fix.patch
@@ -17,7 +17,7 @@ Date: Mon Aug 16 13:16:21 2021 +0100
--- a/gcc/config/aarch64/aarch64.h
+++ b/gcc/config/aarch64/aarch64.h
-@@ -1236,7 +1236,7 @@ extern const char *aarch64_rewrite_mcpu
+@@ -1290,7 +1290,7 @@ extern const char *aarch64_rewrite_mcpu
#define MCPU_TO_MARCH_SPEC_FUNCTIONS \
{ "rewrite_mcpu", aarch64_rewrite_mcpu },
@@ -28,8 +28,8 @@ Date: Mon Aug 16 13:16:21 2021 +0100
# define EXTRA_SPEC_FUNCTIONS \
--- a/gcc/config/host-darwin.cc
+++ b/gcc/config/host-darwin.cc
-@@ -22,6 +22,8 @@
- #include "coretypes.h"
+@@ -23,6 +23,8 @@
+ #include "options.h"
#include "diagnostic-core.h"
#include "config/host-darwin.h"
+#include "hosthooks.h"
@@ -37,9 +37,9 @@ Date: Mon Aug 16 13:16:21 2021 +0100
#include <errno.h>
/* For Darwin (macOS only) platforms, without ASLR (PIE) enabled on the
-@@ -79,3 +81,5 @@ darwin_gt_pch_use_address (void *addr, s
+@@ -181,3 +183,5 @@ darwin_gt_pch_use_address (void *&addr,
- return ret;
+ return 1;
}
+
+const struct host_hooks host_hooks = HOST_HOOKS_INITIALIZER;