summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorYorkie Liu <yorkiefixer@gmail.com>2019-11-19 13:41:10 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:31:13 +0100
commita7d880e830cf786941c14f5fd410a7e918ffcb5d (patch)
tree64b4ef7b6239361d8da8bf4857e2a1374a89c3ed /toolchain
parent3a863da2687ed029ef81c734d233b91dbe1bb7dc (diff)
downloadopenwrt-a7d880e830cf786941c14f5fd410a7e918ffcb5d.tar.gz
openwrt-a7d880e830cf786941c14f5fd410a7e918ffcb5d.tar.bz2
openwrt-a7d880e830cf786941c14f5fd410a7e918ffcb5d.zip
toolchain/gcc: correct the check expr for newer clang
This fixes gcc build error within clang 11.0, it tweaks the version string from LLVM to clang. Signed-off-by: Yorkie Liu <yorkiefixer@gmail.com> (cherry picked from commit 65a561fd0919eafff2363ae8324db64be2a57f77)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index f7390c159e..e2dfcea6cb 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -85,7 +85,7 @@ endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
- $(if $(shell gcc --version 2>&1 | grep LLVM), \
+ $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
CFLAGS="-O2 -fbracket-depth=512 -pipe" \
CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
) \