summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-09 12:21:15 +0100
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:47:42 +0100
commitdde29b2b01e489184882fe718c4a3b9ffcfc3aac (patch)
treec0208606cc0c701ee596ea0514cd8abadbe0dcdc /tools
parent2f75641b1fcc43bf3550ae00a5750477e80d86c5 (diff)
downloadopenwrt-dde29b2b01e489184882fe718c4a3b9ffcfc3aac.tar.gz
openwrt-dde29b2b01e489184882fe718c4a3b9ffcfc3aac.tar.bz2
openwrt-dde29b2b01e489184882fe718c4a3b9ffcfc3aac.zip
tools/coreutils: install readlink
Parts of the build system use non-portable invocation of readlink Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 6bcc1c5331c797004e1b43168eb116d2d14b0102)
Diffstat (limited to 'tools')
-rw-r--r--tools/coreutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 1acdfb9160..c731eafda6 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -15,14 +15,14 @@ PKG_HASH:=8891d349ee87b9ff7870f52b6d9312a9db672d2439d289bc57084771ca21656b
HOST_BUILD_PARALLEL := 1
-BUILD_PROGRAMS = date
+BUILD_PROGRAMS = date readlink
include $(INCLUDE_DIR)/host-build.mk
BUILD_BINS = $(patsubst %,src/%,$(BUILD_PROGRAMS))
HOST_CONFIGURE_ARGS += \
- --enable-install-program=date
+ --enable-install-program=$(subst $(space),$(comma),$(strip $(BUILD_PROGRAMS)))
HOST_MAKE_FLAGS += \
PROGRAMS="$(BUILD_BINS)" \