summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-04-03 01:10:01 +0200
committerRobert Marko <robimarko@gmail.com>2024-04-06 11:24:18 +0200
commitc3e43b7e654982f8f48ec63558806be2647da7e4 (patch)
tree0e0d04c71248b2d3c09572ef7ad46a73ebf3f7b1 /tools
parentd5c4cb0a8d251883d7a17d4426311090d6791249 (diff)
downloadopenwrt-c3e43b7e654982f8f48ec63558806be2647da7e4.tar.gz
openwrt-c3e43b7e654982f8f48ec63558806be2647da7e4.tar.bz2
openwrt-c3e43b7e654982f8f48ec63558806be2647da7e4.zip
tools: make zstd tool core and xz tool non-core
Make zstd tool core and xz tool non-core since zstd is the new default for compression format. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 36a2ae1933..445101c012 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -67,9 +67,9 @@ tools-y += quilt
tools-y += squashfs4
tools-y += sstrip
tools-y += util-linux
+tools-y += xz
tools-y += zip
tools-y += zlib
-tools-y += zstd
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS),y) += liblzo
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_B43_TOOLS),y) += b43-tools
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_BZIP2_TOOLS),y) += bzip2
@@ -153,22 +153,21 @@ endif
# dependency for tools which have patches directory
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/compile)))
-$(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/compile))
+$(foreach tool, $(filter-out zstd,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/zstd/compile))
# make any tool depend on the following to ensure that archives can be unpacked and patched properly
tools-core += libdeflate
tools-core += patch
tools-core += tar
-tools-core += xz
+tools-core += zstd
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(curdir)/%/compile,$(tools-core))))
tools-y += $(tools-core)
# make core tools depend on sed and flock
-$(foreach tool, $(filter-out xz,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
-$(curdir)/xz/compile += $(curdir)/flock/compile
+$(foreach tool, $(filter-out zstd,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
-$(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/xz/compile
+$(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/zstd/compile
tools-y += flock sed
$(curdir)/autoremove := 1