summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-13 12:59:47 -0800
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:07 +0100
commit0340d3ad2d1b6bdc9c58e242d987dd92a98d0db1 (patch)
treed8dff4e64e4e9504a2922ab52716daa5b87aa68e /tools
parente2637a471a647a99ce419177a2bd20dd7507ca80 (diff)
downloadopenwrt-0340d3ad2d1b6bdc9c58e242d987dd92a98d0db1.tar.gz
openwrt-0340d3ad2d1b6bdc9c58e242d987dd92a98d0db1.tar.bz2
openwrt-0340d3ad2d1b6bdc9c58e242d987dd92a98d0db1.zip
flex: Add a lex symlink
Some packages like libpfring assume the presense of lex, which on some other systems is a symlink to flex but not all. Symlink flex to fix compilation. Arch Linux and Fedora do this as far as I know. Signed-off-by: Rosen Penev <rosenp@gmail.com> (backported from 7ef38e42c8440a29d1dc721a9e6184b2e369bc2f)
Diffstat (limited to 'tools')
-rw-r--r--tools/flex/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index 1eff81f345..bb5aecbdfe 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -21,6 +21,11 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
+define Host/Install
+ $(call Host/Install/Default)
+ $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)