summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorThorsten Glaser <tg@mirbsd.org>2018-10-22 21:00:57 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:03 +0100
commit16f4057188b7fd4bc8126600d053a1822231cc36 (patch)
tree938562a1121f7ef439c0ddc6e3c92ad3b971e53c /tools
parent8b07cd6000ddf7c8827114e44e574b094ef16ce4 (diff)
downloadopenwrt-16f4057188b7fd4bc8126600d053a1822231cc36.tar.gz
openwrt-16f4057188b7fd4bc8126600d053a1822231cc36.tar.bz2
openwrt-16f4057188b7fd4bc8126600d053a1822231cc36.zip
build: fix libressl build on x32 (amd64ilp32) host
disable use of assembly code since x32 gets misdetected as amd64 Signed-off-by: Thorsten Glaser <tg@mirbsd.org> (backported from a395563f68fde6f52dbf10913f59f13b8c804cd5)
Diffstat (limited to 'tools')
-rw-r--r--tools/libressl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 4c7e8a7b6e..bb8113a4ad 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -24,4 +24,8 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
HOST_CFLAGS += $(FPIC)
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
$(eval $(call HostBuild))