summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-08-30 15:28:27 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:46:49 +0200
commit2e490e7e46a4f6fbf66fa930a25c2991e24c0f83 (patch)
treee716ad2fa8a339d314c8bf2a7954ecc398bed582 /tools
parent7c811372d823d627e4150ea3b4adcd57a5a2794a (diff)
downloadopenwrt-2e490e7e46a4f6fbf66fa930a25c2991e24c0f83.tar.gz
openwrt-2e490e7e46a4f6fbf66fa930a25c2991e24c0f83.tar.bz2
openwrt-2e490e7e46a4f6fbf66fa930a25c2991e24c0f83.zip
tools: libelf: install pkg-config file
Install the pkg-config definition for libelf in order to allow the kernel build process discover it later on. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit d3f86c9cc3e465fbca51aaadbb274856831ba56c)
Diffstat (limited to 'tools')
-rw-r--r--tools/libelf/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
index 31e2eaf0a8..9fec8308b5 100644
--- a/tools/libelf/Makefile
+++ b/tools/libelf/Makefile
@@ -37,15 +37,17 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib/pkgconfig,include/libelf}
$(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
$(STAGING_DIR_HOST)/include/libelf/
$(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
+ $(CP) $(HOST_BUILD_DIR)/libelf.pc $(STAGING_DIR_HOST)/lib/pkgconfig/
endef
define Host/Clean
rm -rf $(STAGING_DIR_HOST)/include/libelf
rm -f $(STAGING_DIR_HOST)/lib/libelf.a
+ rm -f $(STAGING_DIR_HOST)/lib/pkgconfig/libelf.pc
$(call Host/Clean/Default)
endef