summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 209be34674..4b8df7f484 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -92,6 +92,10 @@ $(curdir)/index: FORCE
$(call ERROR_MESSAGE,WARNING: Applying padding in $$d/Packages to workaround usign SHA-512 bug!); \
{ echo ""; echo ""; } >> Packages;; \
esac; \
+ echo -n '{"architecture": "$(ARCH_PACKAGES)", "packages":{' > index.json; \
+ sed -n -e 's/^Package: \(.*\)$$/"\1":/p' -e 's/^Version: \(.*\)$$/"\1",/p' Packages | tr '\n' ' ' >> index.json; \
+ echo '}}' >> index.json; \
+ sed -i 's/, }}/}}/' index.json; \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES