summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-kirkwood/Makefile2
-rw-r--r--package/boot/uboot-kirkwood/patches/001-ARM-kirkwood-disable-dcache-for-Kirkwood-boards.patch38
2 files changed, 39 insertions, 1 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index 4ce1485a13..1b660bd9be 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_VERSION:=2019.01
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
diff --git a/package/boot/uboot-kirkwood/patches/001-ARM-kirkwood-disable-dcache-for-Kirkwood-boards.patch b/package/boot/uboot-kirkwood/patches/001-ARM-kirkwood-disable-dcache-for-Kirkwood-boards.patch
new file mode 100644
index 0000000000..731f083a98
--- /dev/null
+++ b/package/boot/uboot-kirkwood/patches/001-ARM-kirkwood-disable-dcache-for-Kirkwood-boards.patch
@@ -0,0 +1,38 @@
+From 599f7aa541bb5a658cbfd2af73bd9d2f6e828d43 Mon Sep 17 00:00:00 2001
+From: Chris Packham <judge.packham@gmail.com>
+Date: Mon, 18 Mar 2019 20:51:58 +1300
+Subject: [PATCH] ARM: kirkwood: disable dcache for Kirkwood boards
+
+Prior to commit 93b283d49f93 ("ARM: CPU: arm926ejs: Consolidate cache
+routines to common file") the kirkwood boards didn't have and dcache
+support. The network and usb drivers rely on this. Set
+CONFIG_SYS_DCACHE_OFF in the Kirkwood specific config.h.
+
+Reported-by: Leigh Brown <leigh@solinno.co.uk>
+Signed-off-by: Chris Packham <judge.packham@gmail.com>
+Reviewed-by: Stefan Roese <sr@denx.de>
+Signed-off-by: Stefan Roese <sr@denx.de>
+---
+ arch/arm/mach-kirkwood/include/mach/config.h | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/arch/arm/mach-kirkwood/include/mach/config.h b/arch/arm/mach-kirkwood/include/mach/config.h
+index fcd903887b..aea60688c2 100644
+--- a/arch/arm/mach-kirkwood/include/mach/config.h
++++ b/arch/arm/mach-kirkwood/include/mach/config.h
+@@ -26,6 +26,12 @@
+ #define CONFIG_KIRKWOOD_EGIGA_INIT /* Enable GbePort0/1 for kernel */
+ #define CONFIG_KIRKWOOD_RGMII_PAD_1V8 /* Set RGMII Pad voltage to 1.8V */
+ #define CONFIG_KIRKWOOD_PCIE_INIT /* Enable PCIE Port0 for kernel */
++/*
++ * Disable the dcache. Currently the network driver (mvgbe.c) and USB
++ * EHCI driver (ehci-marvell.c) and possibly others rely on the data
++ * cache being disabled.
++ */
++#define CONFIG_SYS_DCACHE_OFF
+
+ /*
+ * By default kwbimage.cfg from board specific folder is used
+--
+2.20.1
+