summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/usb.mk23
1 files changed, 21 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 88bb4a91eb..f11758c662 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -385,8 +385,7 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_AT91=y \
- CONFIG_USB_EHCI_FSL
+ CONFIG_USB_EHCI_HCD_AT91=y
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
@@ -406,6 +405,26 @@ endef
$(eval $(call KernelPackage,usb2))
+define KernelPackage/usb2-fsl
+ TITLE:=Support for Freescale USB2 controllers
+ DEPENDS:=+kmod-usb-ehci @TARGET_mpc85xx
+ KCONFIG:= \
+ CONFIG_USB_EHCI_HCD_PPC_OF=y \
+ CONFIG_USB_EHCI_FSL=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
+ $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+ AUTOLOAD:=$(call AutoLoad,42,ehci-fsl fsl-mph-dr-of,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb2-fsl/description
+ Kernel support for Freescale USB2 (EHCI) controllers
+endef
+
+$(eval $(call KernelPackage,usb2-fsl))
+
+
define KernelPackage/usb2-pci
TITLE:=Support for PCI USB2 controllers
DEPENDS:=@PCI_SUPPORT +kmod-usb2