summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/prereq-build.mk7
-rw-r--r--rules.mk8
2 files changed, 15 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8fae92ab97..14a2210880 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -8,6 +8,13 @@ include $(INCLUDE_DIR)/prereq.mk
SHELL:=sh
PKG_NAME:=Build dependency
+$(eval $(call TestHostCommand,true, \
+ Please install GNU 'coreutils', \
+ $(TRUE)))
+
+$(eval $(call TestHostCommand,false, \
+ Please install GNU 'coreutils', \
+ $(FALSE); [ $$$$$$$$? = 1 ] && $(TRUE)))
# Required for the toolchain
$(eval $(call TestHostCommand,working-make, \
diff --git a/rules.mk b/rules.mk
index 57d7995d4f..cc7904ac72 100644
--- a/rules.mk
+++ b/rules.mk
@@ -268,6 +268,14 @@ FIND:=find
PATCH:=patch
PYTHON:=python3
+ifeq ($(HOST_OS),Darwin)
+ TRUE:=/usr/bin/env gtrue
+ FALSE:=/usr/bin/env gfalse
+else
+ TRUE:=/usr/bin/env true
+ FALSE:=/usr/bin/env false
+endif
+
INSTALL_BIN:=install -m0755
INSTALL_SUID:=install -m4755
INSTALL_DIR:=install -d -m0755