summaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 632fecb4a3..87b1562c3e 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -18,6 +18,10 @@ opkg_package_files = $(wildcard \
$(foreach dir,$(PACKAGE_SUBDIRS), \
$(foreach pkg,$(1), $(dir)/$(pkg)_*.ipk)))
+apk_package_files = $(wildcard \
+ $(foreach dir,$(PACKAGE_SUBDIRS), \
+ $(foreach pkg,$(1), $(dir)/$(pkg)_*.apk)))
+
# 1: package name
define FeedPackageDir
$(strip $(if $(CONFIG_PER_FEED_REPO), \
@@ -28,7 +32,7 @@ $(strip $(if $(CONFIG_PER_FEED_REPO), \
endef
# 1: destination file
-define FeedSourcesAppend
+define FeedSourcesAppendOPKG
( \
echo 'src/gz %d_core %U/targets/%S/packages'; \
$(strip $(if $(CONFIG_PER_FEED_REPO), \
@@ -41,6 +45,20 @@ define FeedSourcesAppend
) >> $(1)
endef
+# 1: destination file
+define FeedSourcesAppendAPK
+( \
+ echo '%U/targets/%S/packages/packages.adb'; \
+ $(strip $(if $(CONFIG_PER_FEED_REPO), \
+ echo '%U/packages/%A/base/packages.adb'; \
+ $(if $(filter %SNAPSHOT-y,$(VERSION_NUMBER)-$(CONFIG_BUILDBOT)), \
+ echo '%U/targets/%S/kmods/$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)/packages.adb';) \
+ $(foreach feed,$(FEEDS_AVAILABLE), \
+ $(if $(CONFIG_FEED_$(feed)), \
+ echo '$(if $(filter m,$(CONFIG_FEED_$(feed))),# )%U/packages/%A/$(feed)/packages.adb';)))) \
+) >> $(1)
+endef
+
# 1: package name
define GetABISuffix
$(if $(ABIV_$(1)),$(ABIV_$(1)),$(call FormatABISuffix,$(1),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))