summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk23
1 files changed, 0 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4097957277..445b2e353b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -446,29 +446,6 @@ endef
$(eval $(call KernelPackage,crypto-kpp))
-
-define KernelPackage/crypto-lib-blake2s
- TITLE:=BLAKE2s hash function library
- KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
- HIDDEN:=1
- FILES:= \
- $(LINUX_DIR)/lib/crypto/libblake2s.ko \
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
- $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
- imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
define KernelPackage/crypto-lib-chacha20
TITLE:=ChaCha library interface
KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA