summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/fs.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 619ae90bc8..edd2774a63 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -49,8 +49,12 @@ $(eval $(call KernelPackage,fs-afs))
define KernelPackage/fs-autofs4
SUBMENU:=$(FS_MENU)
TITLE:=AUTOFS4 filesystem support
- KCONFIG:=CONFIG_AUTOFS4_FS
- FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
+ KCONFIG:= \
+ CONFIG_AUTOFS4_FS \
+ CONFIG_AUTOFS_FS
+ FILES:= \
+ $(LINUX_DIR)/fs/autofs4/autofs4.ko@lt4.18 \
+ $(LINUX_DIR)/fs/autofs/autofs4.ko@ge4.18
AUTOLOAD:=$(call AutoLoad,30,autofs4)
endef