summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index ba7374ecc3..640557532c 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -411,6 +411,25 @@ define Device/e750a-v4-8M
endef
TARGET_DEVICES += e750a-v4-8M
+define Device/e750g-v8-16M
+ DEVICE_TITLE := Qxwlan E750G v8 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := E750G-V8
+ SUPPORTED_DEVICES := e750g-v8
+ IMAGE_SIZE := 15936k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750g-v8-16M
+
+define Device/e750g-v8-8M
+ $(Device/e750g-v8-16M)
+ DEVICE_TITLE := Qxwlan E750G v8 (8MB flash)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750g-v8-8M
+
define Device/ew-balin
DEVICE_TITLE := Embedded Wireless Balin Platform
DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea