summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/Makefile')
-rw-r--r--target/linux/atheros/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
new file mode 100644
index 0000000000..611345f4bb
--- /dev/null
+++ b/target/linux/atheros/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=atheros
+BOARDNAME:=Atheros
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=2.6.22.4
+
+define Target/Description
+ Build firmware images for Atheros SoC boards
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-madwifi
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))