summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch')
-rw-r--r--target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch324
1 files changed, 0 insertions, 324 deletions
diff --git a/target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch b/target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
deleted file mode 100644
index c0cdba9a0d..0000000000
--- a/target/linux/brcm2708/patches-4.4/0507-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
+++ /dev/null
@@ -1,324 +0,0 @@
-From 22283a63ebaa5d81f228a7d76290da508c6ecc09 Mon Sep 17 00:00:00 2001
-From: Clive Messer <clive.m.messer@gmail.com>
-Date: Mon, 19 Sep 2016 14:01:04 +0100
-Subject: [PATCH] Allo Piano DAC boards: Initial 2 channel (stereo) support
- (#1645)
-
-Add initial 2 channel (stereo) support for Allo Piano DAC (2.0/2.1) boards,
-using allo-piano-dac-pcm512x-audio overlay and allo-piano-dac ALSA ASoC
-machine driver.
-
-NB. The initial support is 2 channel (stereo) ONLY!
-(The Piano DAC 2.1 will only support 2 channel (stereo) left/right output,
- pending an update to the upstream pcm512x codec driver, which will have
- to be submitted via upstream. With the initial downstream support,
- provided by this patch, the Piano DAC 2.1 subwoofer outputs will
- not function.)
-
-Signed-off-by: Baswaraj K <jaikumar@cem-solutions.net>
-Signed-off-by: Clive Messer <clive.messer@digitaldreamtime.co.uk>
-Tested-by: Clive Messer <clive.messer@digitaldreamtime.co.uk>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- arch/arm/boot/dts/overlays/README | 20 +++
- .../allo-piano-dac-pcm512x-audio-overlay.dts | 54 ++++++++
- arch/arm/configs/bcm2709_defconfig | 1 +
- arch/arm/configs/bcmrpi_defconfig | 1 +
- sound/soc/bcm/Kconfig | 7 +
- sound/soc/bcm/Makefile | 2 +
- sound/soc/bcm/allo-piano-dac.c | 144 +++++++++++++++++++++
- 8 files changed, 230 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/allo-piano-dac-pcm512x-audio-overlay.dts
- create mode 100644 sound/soc/bcm/allo-piano-dac.c
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -16,6 +16,7 @@ dtbo-$(RPI_DT_OVERLAYS) += adau1977-adc.
- dtbo-$(RPI_DT_OVERLAYS) += ads1015.dtbo
- dtbo-$(RPI_DT_OVERLAYS) += ads7846.dtbo
- dtbo-$(RPI_DT_OVERLAYS) += akkordion-iqdacplus.dtbo
-+dtbo-$(RPI_DT_OVERLAYS) += allo-piano-dac-pcm512x-audio.dtbo
- dtbo-$(RPI_DT_OVERLAYS) += at86rf233.dtbo
- dtbo-$(RPI_DT_OVERLAYS) += audioinjector-wm8731-audio.dtbo
- dtbo-$(RPI_DT_OVERLAYS) += audremap.dtbo
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -235,6 +235,26 @@ Params: 24db_digital_gain Allow ga
- that does not result in clipping/distortion!)
-
-
-+Name: allo-piano-dac-pcm512x-audio
-+Info: Configures the Allo Piano DAC (2.0/2.1) audio cards.
-+ (NB. This initial support is for 2.0 channel audio ONLY! ie. stereo.
-+ The subwoofer outputs on the Piano 2.1 are not currently supported!)
-+Load: dtoverlay=allo-piano-dac-pcm512x-audio,<param>
-+Params: 24db_digital_gain Allow gain to be applied via the PCM512x codec
-+ Digital volume control.
-+ (The default behaviour is that the Digital
-+ volume control is limited to a maximum of
-+ 0dB. ie. it can attenuate but not provide
-+ gain. For most users, this will be desired
-+ as it will prevent clipping. By appending
-+ the 24db_digital_gain parameter, the Digital
-+ volume control will allow up to 24dB of
-+ gain. If this parameter is enabled, it is the
-+ responsibility of the user to ensure that
-+ the Digital volume control is set to a value
-+ that does not result in clipping/distortion!)
-+
-+
- Name: at86rf233
- Info: Configures the Atmel AT86RF233 802.15.4 low-power WPAN transceiver,
- connected to spi0.0
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/allo-piano-dac-pcm512x-audio-overlay.dts
-@@ -0,0 +1,54 @@
-+/*
-+ * Definitions for Allo Piano DAC (2.0/2.1) boards
-+ *
-+ * NB. The Piano DAC 2.1 board contains 2x TI PCM5142 DAC's. One DAC is stereo
-+ * (left/right) and the other provides a subwoofer output, using DSP on the
-+ * chip for digital high/low pass crossover.
-+ * The initial support for this hardware, that doesn't require any codec driver
-+ * modifications, uses only one DAC chip for stereo (left/right) output, the
-+ * chip with 0x4c slave address. The other chip at 0x4d is currently ignored!
-+ */
-+
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+ compatible = "brcm,bcm2708";
-+
-+ fragment@0 {
-+ target = <&i2s>;
-+ __overlay__ {
-+ status = "okay";
-+ };
-+ };
-+
-+ fragment@1 {
-+ target = <&i2c1>;
-+ __overlay__ {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+ status = "okay";
-+
-+ pcm5142@4c {
-+ #sound-dai-cells = <0>;
-+ compatible = "ti,pcm5142";
-+ reg = <0x4c>;
-+ status = "okay";
-+ };
-+ };
-+ };
-+
-+ fragment@2 {
-+ target = <&sound>;
-+ piano_dac: __overlay__ {
-+ compatible = "allo,piano-dac";
-+ i2s-controller = <&i2s>;
-+ status = "okay";
-+ };
-+ };
-+
-+ __overrides__ {
-+ 24db_digital_gain =
-+ <&piano_dac>,"allo,24db_digital_gain?";
-+ };
-+};
---- a/arch/arm/configs/bcm2709_defconfig
-+++ b/arch/arm/configs/bcm2709_defconfig
-@@ -879,6 +879,7 @@ CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
- CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
- CONFIG_SND_DIGIDAC1_SOUNDCARD=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
-+CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC=m
- CONFIG_SND_SOC_ADAU1701=m
- CONFIG_SND_SOC_WM8804_I2C=m
- CONFIG_SND_SIMPLE_CARD=m
---- a/arch/arm/configs/bcmrpi_defconfig
-+++ b/arch/arm/configs/bcmrpi_defconfig
-@@ -871,6 +871,7 @@ CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
- CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
- CONFIG_SND_DIGIDAC1_SOUNDCARD=m
- CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
-+CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC=m
- CONFIG_SND_SOC_ADAU1701=m
- CONFIG_SND_SOC_WM8804_I2C=m
- CONFIG_SND_SIMPLE_CARD=m
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -114,3 +114,10 @@ config SND_BCM2708_SOC_DIONAUDIO_LOCO
- select SND_SOC_PCM5102a
- help
- Say Y or M if you want to add support for Dion Audio LOCO.
-+
-+config SND_BCM2708_SOC_ALLO_PIANO_DAC
-+ tristate "Support for Allo Piano DAC"
-+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+ select SND_SOC_PCM512x_I2C
-+ help
-+ Say Y or M if you want to add support for Allo Piano DAC.
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -19,6 +19,7 @@ snd-soc-raspidac3-objs := raspidac3.o
- snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
- snd-soc-digidac1-soundcard-objs := digidac1-soundcard.o
- snd-soc-dionaudio-loco-objs := dionaudio_loco.o
-+snd-soc-allo-piano-dac-objs := allo-piano-dac.o
-
- obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
-@@ -35,3 +36,4 @@ obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3)
- obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
- obj-$(CONFIG_SND_DIGIDAC1_SOUNDCARD) += snd-soc-digidac1-soundcard.o
- obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO) += snd-soc-dionaudio-loco.o
-+obj-$(CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC) += snd-soc-allo-piano-dac.o
---- /dev/null
-+++ b/sound/soc/bcm/allo-piano-dac.c
-@@ -0,0 +1,144 @@
-+/*
-+ * ALSA ASoC Machine Driver for Allo Piano DAC
-+ *
-+ * Author: Baswaraj K <jaikumar@cem-solutions.net>
-+ * Copyright 2016
-+ * based on code by Daniel Matuschek <info@crazy-audio.com>
-+ * based on code by Florian Meier <florian.meier@koalo.de>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+
-+static bool digital_gain_0db_limit = true;
-+
-+static int snd_allo_piano_dac_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+ if (digital_gain_0db_limit) {
-+ int ret;
-+ struct snd_soc_card *card = rtd->card;
-+
-+ ret = snd_soc_limit_volume(card, "Digital Playback Volume",
-+ 207);
-+ if (ret < 0)
-+ dev_warn(card->dev, "Failed to set volume limit: %d\n",
-+ ret);
-+ }
-+
-+ return 0;
-+}
-+
-+static int snd_allo_piano_dac_hw_params(
-+ struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
-+
-+ unsigned int sample_bits =
-+ snd_pcm_format_physical_width(params_format(params));
-+
-+ return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
-+}
-+
-+/* machine stream operations */
-+static struct snd_soc_ops snd_allo_piano_dac_ops = {
-+ .hw_params = snd_allo_piano_dac_hw_params,
-+};
-+
-+static struct snd_soc_dai_link snd_allo_piano_dac_dai[] = {
-+{
-+ .name = "Piano DAC",
-+ .stream_name = "Piano DAC HiFi",
-+ .cpu_dai_name = "bcm2708-i2s.0",
-+ .codec_dai_name = "pcm512x-hifi",
-+ .platform_name = "bcm2708-i2s.0",
-+ .codec_name = "pcm512x.1-004c",
-+ .dai_fmt = SND_SOC_DAIFMT_I2S |
-+ SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBS_CFS,
-+ .ops = &snd_allo_piano_dac_ops,
-+ .init = snd_allo_piano_dac_init,
-+},
-+};
-+
-+/* audio machine driver */
-+static struct snd_soc_card snd_allo_piano_dac = {
-+ .name = "PianoDAC",
-+ .owner = THIS_MODULE,
-+ .dai_link = snd_allo_piano_dac_dai,
-+ .num_links = ARRAY_SIZE(snd_allo_piano_dac_dai),
-+};
-+
-+static int snd_allo_piano_dac_probe(struct platform_device *pdev)
-+{
-+ int ret = 0;
-+
-+ snd_allo_piano_dac.dev = &pdev->dev;
-+
-+ if (pdev->dev.of_node) {
-+ struct device_node *i2s_node;
-+ struct snd_soc_dai_link *dai;
-+
-+ dai = &snd_allo_piano_dac_dai[0];
-+ i2s_node = of_parse_phandle(pdev->dev.of_node,
-+ "i2s-controller", 0);
-+
-+ if (i2s_node) {
-+ dai->cpu_dai_name = NULL;
-+ dai->cpu_of_node = i2s_node;
-+ dai->platform_name = NULL;
-+ dai->platform_of_node = i2s_node;
-+ }
-+
-+ digital_gain_0db_limit = !of_property_read_bool(
-+ pdev->dev.of_node, "allo,24db_digital_gain");
-+ }
-+
-+ ret = snd_soc_register_card(&snd_allo_piano_dac);
-+ if (ret)
-+ dev_err(&pdev->dev,
-+ "snd_soc_register_card() failed: %d\n", ret);
-+
-+ return ret;
-+}
-+
-+static int snd_allo_piano_dac_remove(struct platform_device *pdev)
-+{
-+ return snd_soc_unregister_card(&snd_allo_piano_dac);
-+}
-+
-+static const struct of_device_id snd_allo_piano_dac_of_match[] = {
-+ { .compatible = "allo,piano-dac", },
-+ { /* sentinel */ },
-+};
-+MODULE_DEVICE_TABLE(of, snd_allo_piano_dac_of_match);
-+
-+static struct platform_driver snd_allo_piano_dac_driver = {
-+ .driver = {
-+ .name = "snd-allo-piano-dac",
-+ .owner = THIS_MODULE,
-+ .of_match_table = snd_allo_piano_dac_of_match,
-+ },
-+ .probe = snd_allo_piano_dac_probe,
-+ .remove = snd_allo_piano_dac_remove,
-+};
-+
-+module_platform_driver(snd_allo_piano_dac_driver);
-+
-+MODULE_AUTHOR("Baswaraj K <jaikumar@cem-solutions.net>");
-+MODULE_DESCRIPTION("ALSA ASoC Machine Driver for Allo Piano DAC");
-+MODULE_LICENSE("GPL v2");