summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsvalo <me@valo.space>2017-10-22 09:56:53 +0200
committersvalo <me@valo.space>2017-10-22 09:57:57 +0200
commit906c80b19e2ee8bfd0d0f808c687bcef0c9d68ff (patch)
treee6c1f747b30f1d49c49173e076acdfef89fea58b /PKGBUILD
parent13112a3d0c536106f11a5f9a1b678e127547f783 (diff)
downloaddino-git-906c80b19e2ee8bfd0d0f808c687bcef0c9d68ff.tar.gz
dino-git-906c80b19e2ee8bfd0d0f808c687bcef0c9d68ff.tar.bz2
dino-git-906c80b19e2ee8bfd0d0f808c687bcef0c9d68ff.zip
Improved PKGBUILD
[PKGBUILD] Allow to disable any or all of the plugins
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b06cda..8158216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
# Contributor: svalo <me@valo.space>
pkgname=dino-git
-pkgver=r178.54a25fd
-pkgrel=1
+pkgver=r179.9d8e1e8
+pkgrel=2
pkgdesc="Simple and modern Jabber/XMPP client written in vala"
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/dino/dino"
license=('GPL3')
-depends=('glib2>=2.38' 'glib-networking' 'gtk3>=3.22' 'gpgme' 'libgee>=0.10' 'libgcrypt' 'libsoup' 'sqlite' )
+depends=('glib2>=2.38' 'glib-networking' 'gtk3>=3.22' 'gpgme' 'libgee>=0.10' 'libgcrypt' 'libsoup' 'sqlite')
makedepends=('git' 'cmake' 'vala>=0.30' 'ninja')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('dino::git+https://github.com/dino/dino')
sha512sums=('SKIP')
+# Any or all of the following plugin can be disabled: omemo, openpgp, http-files. Populate following string as per your needs and uncomment it
+#_DISABLE_PLUGINS="--disable-plugin='omemo;openpgp;http-files'"
+
pkgver() {
cd "${srcdir}/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -22,7 +25,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- ./configure --prefix="/usr" --with-tests CC="$CC" CFLAGS="$CFLAGS" VALACFLAGS="$VALACFLAGS"
+ ./configure $_DISABLE_PLUGINS --prefix="/usr" --with-tests CC="$CC" CFLAGS="$CFLAGS" VALACFLAGS="$VALACFLAGS"
make
}