summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5de5f09..9556445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: svalo <me@valo.space>
pkgname=dino-git
-pkgver=r128.e3e6a42
+pkgver=r135.30818b3
pkgrel=1
pkgdesc="Simple and modern Jabber/XMPP client written in vala"
arch=('i686' 'x86_64' 'aarch64')
@@ -22,7 +22,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- ./configure --prefix="/usr"
+ ./configure --prefix="/usr" --with-tests CC="$CC" CFLAGS="$CFLAGS" VALACFLAGS="$VALACFLAGS"
make
}
@@ -30,3 +30,12 @@ package() {
cd "${srcdir}/${pkgname%-git}"
make DESTDIR="${pkgdir}/" install
}
+
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+ echo "Executing xmpp-vala-test:"
+ build/xmpp-vala-test
+ echo
+ echo "Executing signal-protocol-vala-test:"
+ build/signal-protocol-vala-test
+}