summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeppia <seppia@seppia.net>2018-06-02 13:03:05 +0200
committerSeppia <seppia@seppia.net>2018-06-02 13:03:05 +0200
commit2a98d3a18c7c1e31ec6e0a1d2ffa7d7572e281e6 (patch)
tree1baf1a0e0b5084ff22389dd1fca38c29156d060c /PKGBUILD
downloadrepofish-2a98d3a18c7c1e31ec6e0a1d2ffa7d7572e281e6.tar.gz
repofish-2a98d3a18c7c1e31ec6e0a1d2ffa7d7572e281e6.tar.bz2
repofish-2a98d3a18c7c1e31ec6e0a1d2ffa7d7572e281e6.zip
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..6cff539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Seppia <seppia@seppio.fish>
+pkgname=repofish
+pkgver=0.1
+pkgrel=1
+pkgdesc="My friends told me to make available this script I wrote to manage my local archlinux repo and AUR packages, so here it is."
+arch=('any')
+url="https://git.seppia.net/repofish.git"
+license=('GPLv3')
+groups=()
+depends=('curl git jq')
+provides=("${pkgname}")
+conflicts=("${pkgname}","${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("https://git.seppia.net/repofish.git/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6043e48e168bf741c915ec5e9e870791e03b7021d54b6cb8c837c692d93f93c5')
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -D repo.sh $pkgdir/usr/bin/repofish
+}