summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjk <jk@vin.ovh>2021-09-23 17:31:21 -0500
committerjk <jk@vin.ovh>2021-09-23 17:31:21 -0500
commit19df2824f92d136baa95964790803ad25f6c27b7 (patch)
treefa14ba61af7e212494d21fa733488cec40373413 /PKGBUILD
parent682f730ef81785b39fcf7d0c6967f6e20f0f4c7c (diff)
downloadungoogled-chromium-19df2824f92d136baa95964790803ad25f6c27b7.tar.gz
ungoogled-chromium-19df2824f92d136baa95964790803ad25f6c27b7.tar.bz2
ungoogled-chromium-19df2824f92d136baa95964790803ad25f6c27b7.zip
upgpkg: ungoogled-chromium 93.0.4577.82-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64a396d..a450041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,10 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=92.0.4515.159
+pkgver=93.0.4577.82
pkgrel=1
_launcher_ver=8
-_gcc_patchset=7
+_gcc_patchset=6
pkgdesc="A lightweight approach to removing Google web service dependency"
arch=('x86_64')
url="https://github.com/Eloston/ungoogled-chromium"
@@ -21,7 +21,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'python2')
+ 'java-runtime-headless')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -29,20 +29,24 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland'
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- extend-enable-accelerated-video-decode-flag.patch
linux-sandbox-syscall-broker-use-struct-kernel_stat.patch
linux-sandbox-fix-fstatat-crash.patch
+ replace-blacklist-with-ignorelist.patch
sql-make-VirtualCursor-standard-layout-type.patch
- chromium-freetype-2.11.patch
+ chromium-93-ffmpeg-4.4.patch
+ chromium-harfbuzz-3.0.0.patch
+ skia-harfbuzz-3.0.0.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('d97d337d0d70e959a75f1f510f5d78d2b57b5bf24573b7ade9fff9f26a7cfd11'
+sha256sums=('5d66214858fcba11a8f733d7a6fab61ed10e13e7df4ed37e63b66a0370fb2853'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- '53a2cbb1b58d652d5424ff9040b6a51b9dc6348ce3edc68344cd0d25f1f4beb2'
- '66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
+ 'a44ffd9e25fcbd8b3cc778871890e4da6fe12600ad549c807e1d03f61f0cdf73'
'268e18ad56e5970157b51ec9fc8eb58ba93e313ea1e49c842a1ed0820d9c1fa3'
'253348550d54b8ae317fd250f772f506d2bae49fb5dc75fe15d872ea3d0e04a5'
+ 'd3344ba39b8c6ed202334ba7f441c70d81ddf8cdb15af1aa8c16e9a3a75fbb35'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
- '7ef689cd6b2f85f2b76b2a10ecede003cfa0c2da15acc998ecbc445f2c95ced6'
+ '1a9e074f417f8ffd78bcd6874d8e2e74a239905bf662f76a7755fa40dc476b57'
+ '7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928'
+ 'dae11dec5088eb1b14045d8c9862801a342609c15701d7c371e1caccf46e1ffd'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
provides=('chromium')
conflicts=('chromium')
@@ -51,7 +55,7 @@ source=(${source[@]}
chromium-drirc-disable-10bpc-color-configs.conf
wayland-egl.patch)
sha256sums=(${sha256sums[@]}
- '452d52be91d6183ea2f1728b83f5973fc480591b9a3625742c108cfbf6357588'
+ 'ac6ff40201f389ca43a07563f7fefc2b33f956f7867d7fa8ff65312019496640'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574')
@@ -99,8 +103,15 @@ prepare() {
# runtime -- this allows signing into Chromium without baked-in values
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
- # Fix build with FreeType 2.11 (patch from Gentoo)
- patch -Np1 -i ../chromium-freetype-2.11.patch
+ # Fix build with older ffmpeg
+ patch -Np1 -i ../chromium-93-ffmpeg-4.4.patch
+
+ # Fix build with harfbuzz 3.0.0
+ patch -Np1 -i ../chromium-harfbuzz-3.0.0.patch
+ patch -Np1 -d third_party/skia <../skia-harfbuzz-3.0.0.patch
+
+ # Revert transition to -fsanitize-ignorelist (needs newer clang)
+ patch -Rp1 -i ../replace-blacklist-with-ignorelist.patch
# Upstream fixes
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
@@ -111,7 +122,13 @@ prepare() {
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
# Fixes for building with libstdc++ instead of libc++
+ patch -Np1 -i ../patches/chromium-93-pdfium-include.patch
patch -Np1 -i ../patches/chromium-90-ruy-include.patch
+ patch -Np1 -i ../patches/chromium-93-HashPasswordManager-include.patch
+ patch -Np1 -i ../patches/chromium-93-BluetoothLowEnergyScanFilter-include.patch
+ patch -Np1 -i ../patches/chromium-93-ClassProperty-include.patch
+ patch -Np1 -i ../patches/chromium-93-DevToolsEmbedderMessageDispatcher-include.patch
+ patch -Np1 -i ../patches/chromium-93-ScopedTestDialogAutoConfirm-include.patch
# Wayland/EGL regression (crbug #1071528 #1071550)
patch -Np1 -i ../wayland-egl.patch
@@ -160,6 +177,7 @@ build() {
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'is_official_build=true' # implies is_cfi=true on x86_64
+ 'blink_enable_generated_code_formatting=false'
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
'rtc_use_pipewire=true'