summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeppia <seppia@seppio.fish>2018-11-02 11:45:50 +0100
committerSeppia <seppia@seppio.fish>2018-11-02 11:45:50 +0100
commit395d5745a540ee3e197834b7af6feb2fb094083e (patch)
treef4c154236360034fca9ad0cc7b732148ec8eb7cf /PKGBUILD
parent6b2215b71eee485402c31f6afa1f44a4c2fda11c (diff)
downloadungoogled-chromium-395d5745a540ee3e197834b7af6feb2fb094083e.tar.gz
ungoogled-chromium-395d5745a540ee3e197834b7af6feb2fb094083e.tar.bz2
ungoogled-chromium-395d5745a540ee3e197834b7af6feb2fb094083e.zip
Adds patch resolving a build failure against harfbuzz 2.0
Based on https://bugs.gentoo.org/669034
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae1dd73..5421b57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,10 +26,12 @@ provides=('chromium')
conflicts=('chromium')
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- https://github.com/Eloston/ungoogled-chromium/archive/$pkgver-$pkgrel.tar.gz)
+ https://github.com/Eloston/ungoogled-chromium/archive/$pkgver-$pkgrel.tar.gz
+ chromium-harfbuzz-2.0.patch)
sha256sums=('c914f86c4c8375b719eca89ea89dbec4ae3d09df3f758d5f7c91d4914d290449'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- '9731ddfc654bd74d2da26ccecdbe9262aed7f3ff6ad5b91571ae4b83ecf19159')
+ '9731ddfc654bd74d2da26ccecdbe9262aed7f3ff6ad5b91571ae4b83ecf19159'
+ 'bad4d4a3065f1432d5f9189e29c6bf1d7fe1d365b6c7c4ff51b294569b20e962')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -66,6 +68,8 @@ prepare() {
cd "$srcdir/chromium-$pkgver"
+ patch -Np1 -i ../chromium-harfbuzz-2.0.patch
+
msg2 'Pruning binaries'
python "$_buildkit_cli" prune -b "$_config_bundle" ./
msg2 'Applying patches'