summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjk <jk@vin.ovh>2021-06-12 10:32:15 -0500
committerjk <jk@vin.ovh>2021-06-12 10:32:15 -0500
commit4e5bc82a42277ef918ce4986a544eb54cc9dcf10 (patch)
tree2d5b5891b6ba96857be80f8bdb8e3e2b9db4c424 /PKGBUILD
parent9b963262270fb4c8931969effe48ea6f702fa43b (diff)
downloadungoogled-chromium-4e5bc82a42277ef918ce4986a544eb54cc9dcf10.tar.gz
ungoogled-chromium-4e5bc82a42277ef918ce4986a544eb54cc9dcf10.tar.bz2
ungoogled-chromium-4e5bc82a42277ef918ce4986a544eb54cc9dcf10.zip
upgpkg: ungoogled-chromium 91.0.4472.101-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b957f7d..c5e615a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=91.0.4472.77
+pkgver=91.0.4472.101
pkgrel=1
_launcher_ver=7
_gcc_patchset=5
@@ -38,27 +38,25 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
fix-crash-in-ThemeService.patch
unbundle-use-char16_t-as-UCHAR_TYPE.patch
- add-clang-nomerge-attribute-to-CheckError.patch
+ extend-enable-accelerated-video-decode-flag.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-glibc-2.33.patch
- unexpire-accelerated-video-decode-flag.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('45d5a43ef798d20313c78fa8a075be0c22055e39c8481eb53eabda81df901b31'
+sha256sums=('78146192aaae7771d9130c2828e1081d940da32af3aadcb73578521683307eb4'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'171525009003a9ed1182cfcb6f407d7169d9a731a474304e263029376719f55a'
'3cfe46e181cb9d337c454b5b5adbf5297052f29cd617cdee4380eeb1943825d8'
'59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d'
- '50133dd196d288ad538bb536aa51dccd6cb4aacfd9a60160f77e8fb16034b460'
+ '66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
- '82a85105fc33b92a84dabb7ed6725ccbb56f1075c11f9f3f43bb8ff724f88847'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
source=(${source[@]}
$_pkgname-$_uc_ver.tar.gz::https://github.com/$_uc_usr/ungoogled-chromium/archive/$_uc_ver.tar.gz
chromium-drirc-disable-10bpc-color-configs.conf
wayland-egl.patch)
sha256sums=(${sha256sums[@]}
- 'f93021dab9fd8496beb57a3defc90233258e7128c3141a1a9d9a0c45f29967e1'
+ '3826409802280c7a565db1c532d6467976f3b3ec59b9259f432615b67dc046ad'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574')
@@ -106,18 +104,13 @@ prepare() {
# runtime -- this allows signing into Chromium without baked-in values
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
- # https://crbug.com/1207478
- patch -Np0 -i ../unexpire-accelerated-video-decode-flag.patch
-
# https://crbug.com/1164975
patch -Np1 -i ../chromium-glibc-2.33.patch
# Upstream fixes
#patch -Np1 -i ../fix-crash-in-ThemeService.patch
patch -Np1 -i ../unbundle-use-char16_t-as-UCHAR_TYPE.patch
-
- # Revert addition of [[clang::nomerge]] attribute; not supported by clang 11
- patch -Rp1 -i ../add-clang-nomerge-attribute-to-CheckError.patch
+ patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
@@ -178,7 +171,6 @@ build() {
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'is_official_build=true' # implies is_cfi=true on x86_64
- 'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
'rtc_use_pipewire=true'