summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjk <jk@vin.ovh>2021-05-02 17:59:14 -0500
committerjk <jk@vin.ovh>2021-05-02 17:59:14 -0500
commit7ecdd829ffed057f4a491f4686c819d58e1bfb97 (patch)
tree20d4eb7259449494f538433248b494f443024220 /PKGBUILD
parent52b57d259c78329df5924eafce7747650ee54bbb (diff)
downloadungoogled-chromium-7ecdd829ffed057f4a491f4686c819d58e1bfb97.tar.gz
ungoogled-chromium-7ecdd829ffed057f4a491f4686c819d58e1bfb97.tar.bz2
ungoogled-chromium-7ecdd829ffed057f4a491f4686c819d58e1bfb97.zip
use fixed flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e64182..0725399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -186,9 +186,8 @@ build() {
_ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
- # remove flags the break building
- CFLAGS=${CFLAGS/-fcf-protection}
- CFLAGS=${CFLAGS/-fexceptions}
+ # use fixed flags as system flags break build
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
CXXFLAGS="$CFLAGS"
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)