summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 23 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e06a11b..08b5ea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=85.0.4183.121
+pkgver=86.0.4240.75
pkgrel=1
_launcher_ver=6
-_gcc_patchset=2
+_gcc_patchset=6
_pkgname=$(echo $pkgname | cut -d\- -f1-2)
_pkgver=$(echo $pkgver | cut -d\. -f1-4)
# ungoogled chromium variables
-_uc_ver=$pkgver-1
+_uc_ver=86.0.4240.80-1
_uc_usr=Eloston
-_uc_sum='038fdbecb3a93535a60f02482eff29782e41deb2b171d2eb4511d56e7f103c95'
+_uc_sum='9bc0946f661942b182b12fdec024b12b337aa895f3c39a321916bafe297e97a1'
_uc_url="$_pkgname-$_uc_ver.tar.gz::https://github.com/$_uc_usr/ungoogled-chromium/archive/$_uc_ver.tar.gz"
pkgdesc="A lightweight approach to removing Google web service dependency"
arch=('x86_64')
@@ -28,7 +28,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'mesa' 'ninja' 'nodejs' 'git' 'libva'
- 'libpipewire02' 'clang' 'lld' 'gn-m85' 'java-runtime-headless'
+ 'libpipewire02' 'clang' 'lld' 'gn' 'java-runtime-headless'
'python2-setuptools')
optdepends=('pepper-flash: support for Flash content'
'libpipewire02: WebRTC desktop sharing under Wayland'
@@ -44,20 +44,22 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-drirc-disable-10bpc-color-configs.conf
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch
- intel-vp9-quirk.patch
+ fix-invalid-end-iterator-usage-in-CookieMonster.patch
+ only-fall-back-to-the-i965-driver-if-we-re-on-iHD.patch
+ remove-dead-reloc-in-nonalloc-LD-flags.patch
+ check-for-enable-accelerated-video-decode-on-Linux.patch
wayland-egl.patch
- nvidia-vdpau.patch
chromium-skia-harmony.patch)
-sha256sums=('e018547e54566410fb365d9f3dae10037c30fca5debe6ba8baceef3ad3b03d28'
+sha256sums=('dd7a41eda5f984e44474d7e6fb25b5df88c1c924a1a3966189f037f7d325bcb5'
$_uc_sum
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
- '2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e'
- '0f041d655335cd2a4773ae7ca5e301a0ff12c6c53f57b7cf6651c268e0420a1c'
- 'a25fc6fccb84fd0a58a799661cd9c4ffeb2731fa49268f43aa7108f1542c5af6'
- '34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574'
- '8095bf73afbca7c2b07306c5b4dd8f79b66e1053fa4e58b07f71ef938be603f1'
+ '6f9ab35fa2c9e6e34ec454b829b7b87adaebc10cacecd1ac1daa67035ee44aba'
+ '69d8b7a439db1af4713245ddf5f44ca647283ba833a8733e848033ebdaf03cdc'
+ '7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300'
+ '7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790'
+ '03d03a39b2afa40083eb8ccb9616a51619f71da92348effc8ee289cbda10128b'
+ 'bf86923eaee5529ab9fb6148bd6c33a73c8746ab1b4ade0cd3b761109bc55826'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -99,25 +101,21 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # https://crbug.com/1095962
- patch -Np1 -i ../media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch
+ # Upstream fixes
+ patch -Np1 -i ../fix-invalid-end-iterator-usage-in-CookieMonster.patch
+ patch -Np1 -i ../only-fall-back-to-the-i965-driver-if-we-re-on-iHD.patch
+ #patch -Np1 -i ../remove-dead-reloc-in-nonalloc-LD-flags.patch
+ patch -Np1 -i ../check-for-enable-accelerated-video-decode-on-Linux.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../patches/chromium-85-NearbyShareEncryptedMetadataKey-include.patch
- patch -Np1 -i ../patches/chromium-85-sim_hash-include.patch
+ patch -Np1 -i ../patches/chromium-86-nearby-include.patch
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
- # Intel KabyLake/GeminiLake VP9 quirk
- patch -Np1 -i ../intel-vp9-quirk.patch
-
# Wayland/EGL regression (crbug #1071528 #1071550)
patch -Np1 -i ../wayland-egl.patch
- # NVIDIA vdpau-wrapper
- patch -Np1 -i ../nvidia-vdpau.patch
-
# Ungoogled Chromium changes
_ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
_utils="${_ungoogled_repo}/utils"
@@ -204,7 +202,7 @@ build() {
CXXFLAGS+=' -Wno-unknown-warning-option'
msg2 'Configuring Chromium'
- gn-m85 gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
+ gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
msg2 'Building Chromium'
ninja -C out/Release chrome chrome_sandbox chromedriver
}