summaryrefslogtreecommitdiffstats
path: root/src/mainboard/google/auron/Makefile.inc
diff options
context:
space:
mode:
authorMatt DeVillier <matt.devillier@gmail.com>2019-10-08 17:23:06 -0500
committerNico Huber <nico.h@gmx.de>2019-11-04 19:43:44 +0000
commit2449895709f6d75c26fd4a415ec761f1cee2f7dd (patch)
tree1765553f56c7068a4ccac11ff3092972f445b23d /src/mainboard/google/auron/Makefile.inc
parent7736bfc443a913a9cde46406bcfc38015ec71f47 (diff)
downloadcoreboot-2449895709f6d75c26fd4a415ec761f1cee2f7dd.tar.gz
coreboot-2449895709f6d75c26fd4a415ec761f1cee2f7dd.tar.bz2
coreboot-2449895709f6d75c26fd4a415ec761f1cee2f7dd.zip
google/auron: hook up libgfxinit
Internal/external displays functional on all variants other than Samus. Unable to verify external outputs on Samus (USB-C using DP/HDMI adapter). Test: build/boot lulu variant with libgfxinit, verify internal/ external displays functional prior to OS display driver loaded. Both linear framebuffer and scaled VGA text modes functional. Change-Id: I867b2604861ebae02936e7fc0e7230a6adcb2d20 Signed-off-by: Matt DeVillier <matt.devillier@gmail.com> Reviewed-on: https://review.coreboot.org/c/coreboot/+/36107 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'src/mainboard/google/auron/Makefile.inc')
-rw-r--r--src/mainboard/google/auron/Makefile.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mainboard/google/auron/Makefile.inc b/src/mainboard/google/auron/Makefile.inc
index 6b1de0536c12..ca4247079615 100644
--- a/src/mainboard/google/auron/Makefile.inc
+++ b/src/mainboard/google/auron/Makefile.inc
@@ -35,3 +35,5 @@ subdirs-y += variants/$(VARIANT_DIR)/spd
CPPFLAGS_common += -I$(src)/mainboard/$(MAINBOARDDIR)/variants/$(VARIANT_DIR)/include
romstage-y += variants/$(VARIANT_DIR)/gpio.c
+
+ramstage-$(CONFIG_MAINBOARD_USE_LIBGFXINIT) += gma-mainboard.ads