summaryrefslogtreecommitdiffstats
path: root/src/mainboard/google/auron/variants/lulu/spd/Makefile.inc
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2019-10-07 23:56:05 +0300
committerPatrick Georgi <pgeorgi@google.com>2019-10-09 22:16:40 +0000
commit84c491a8c8948c3f174947aa8e8b9c2d2ca90739 (patch)
tree23fe99a1c5b9e5c3ed02b36db4c35a1decab079c /src/mainboard/google/auron/variants/lulu/spd/Makefile.inc
parentae47a6f4fa4af9495dd907a4beb7d1fc2c137fe3 (diff)
downloadcoreboot-84c491a8c8948c3f174947aa8e8b9c2d2ca90739.tar.gz
coreboot-84c491a8c8948c3f174947aa8e8b9c2d2ca90739.tar.bz2
coreboot-84c491a8c8948c3f174947aa8e8b9c2d2ca90739.zip
mb/[google/intel/lenovo]/*: fix posix shell bug with SPD files
FreeBSD's sh (basic posix shell) did not interpret the '\%o' escape in the same way bash/zsh do. As a result, the decoded files ended up with ASCII numbers instead of the decoded binary data. Change-Id: I95b414d959e5cd4479fcf100adcf390562032c68 Signed-off-by: Greg V <greg@unrelenting.technology> Reviewed-on: https://review.coreboot.org/c/coreboot/+/35867 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Paul Menzel <paulepanter@users.sourceforge.net> Reviewed-by: Tim Wawrzynczak <twawrzynczak@chromium.org> Reviewed-by: Patrick Georgi <pgeorgi@google.com>
Diffstat (limited to 'src/mainboard/google/auron/variants/lulu/spd/Makefile.inc')
-rw-r--r--src/mainboard/google/auron/variants/lulu/spd/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mainboard/google/auron/variants/lulu/spd/Makefile.inc b/src/mainboard/google/auron/variants/lulu/spd/Makefile.inc
index bc1454f2026b..86cb2d2119a7 100644
--- a/src/mainboard/google/auron/variants/lulu/spd/Makefile.inc
+++ b/src/mainboard/google/auron/variants/lulu/spd/Makefile.inc
@@ -42,7 +42,7 @@ SPD_DEPS := $(foreach f, $(SPD_SOURCES), src/mainboard/$(MAINBOARDDIR)/variants/
$(SPD_BIN): $(SPD_DEPS)
for f in $+; \
do for c in $$(cat $$f | grep -v ^#); \
- do printf $$(printf '\%o' 0x$$c); \
+ do printf $$(printf '\\%o' 0x$$c); \
done; \
done > $@