summaryrefslogtreecommitdiffstats
path: root/BaseTools/Source/C/PyUtility/setup.py
diff options
context:
space:
mode:
authorYonghong Zhu <yonghong.zhu@intel.com>2018-09-13 14:12:00 +0800
committerYonghong Zhu <yonghong.zhu@intel.com>2018-10-15 10:23:36 +0800
commit6974c784cbfcdf61725f4f28ecca34991774369f (patch)
treed3cb6e05528cc220df9c33b8ab17ff6a68cf7b48 /BaseTools/Source/C/PyUtility/setup.py
parent0e982cf03dd5023b90def60c3656e5e18135ebac (diff)
downloadedk2-6974c784cbfcdf61725f4f28ecca34991774369f.tar.gz
edk2-6974c784cbfcdf61725f4f28ecca34991774369f.tar.bz2
edk2-6974c784cbfcdf61725f4f28ecca34991774369f.zip
BaseTools: remove the not used PyUtility file
the PyUtility is not used, so we remove it. (re-add this patch since it be reverted in Python3 migration patches, but this check is not related with Python3) Cc: Liming Gao <liming.gao@intel.com> Contributed-under: TianoCore Contribution Agreement 1.1 Signed-off-by: Yonghong Zhu <yonghong.zhu@intel.com> Reviewed-by: Liming Gao <liming.gao@intel.com>
Diffstat (limited to 'BaseTools/Source/C/PyUtility/setup.py')
-rw-r--r--BaseTools/Source/C/PyUtility/setup.py42
1 files changed, 0 insertions, 42 deletions
diff --git a/BaseTools/Source/C/PyUtility/setup.py b/BaseTools/Source/C/PyUtility/setup.py
deleted file mode 100644
index e4d407d84f..0000000000
--- a/BaseTools/Source/C/PyUtility/setup.py
+++ /dev/null
@@ -1,42 +0,0 @@
-## @file
-# package and install PyEfiCompressor extension
-#
-# Copyright (c) 2008, Intel Corporation. All rights reserved.<BR>
-#
-# This program and the accompanying materials
-# are licensed and made available under the terms and conditions of the BSD License
-# which accompanies this distribution. The full text of the license may be found at
-# http://opensource.org/licenses/bsd-license.php
-#
-# THE PROGRAM IS DISTRIBUTED UNDER THE BSD LICENSE ON AN "AS IS" BASIS,
-# WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED.
-#
-
-##
-# Import Modules
-#
-from distutils.core import setup, Extension
-import os
-
-if 'BASE_TOOLS_PATH' not in os.environ:
- raise "Please define BASE_TOOLS_PATH to the root of base tools tree"
-
-BaseToolsDir = os.environ['BASE_TOOLS_PATH']
-setup(
- name="PyUtility",
- version="0.01",
- ext_modules=[
- Extension(
- 'PyUtility',
- sources=[
- 'PyUtility.c'
- ],
- include_dirs=[
- os.path.join(BaseToolsDir, 'Source', 'C', 'Include'),
- os.path.join(BaseToolsDir, 'Source', 'C', 'Include', 'Ia32'),
- os.path.join(BaseToolsDir, 'Source', 'C', 'Common')
- ],
- )
- ],
- )
-