summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNico Huber <nico.h@gmx.de>2019-09-24 18:31:38 +0200
committerNico Huber <nico.h@gmx.de>2019-11-06 08:46:07 +0000
commit2f6936bd926b6d4f21680e2cdc160fc580c3ecb3 (patch)
treeb58cac0e2009b908f72907c7b098c2de4065c768 /meson.build
parentb863127a6f6e538c60fb66716db6aaa44d8726ff (diff)
downloadflashrom-2f6936bd926b6d4f21680e2cdc160fc580c3ecb3.tar.gz
flashrom-2f6936bd926b6d4f21680e2cdc160fc580c3ecb3.tar.bz2
flashrom-2f6936bd926b6d4f21680e2cdc160fc580c3ecb3.zip
util/getversion,meson: Add script to allow version info with Meson
Add `util/getversion.sh` that retrieves version information from a `versioninfo.inc` (what we use for releases) if present or uses `util/getrevision.sh` if not. Let Meson use it for flashrom's version. It seems Meson doesn't generate the manual page at all, so the `--man-date` command is currently unused. Change-Id: I401e5638509c4a573bc0cb17ebc5fa76df9700b5 Signed-off-by: Nico Huber <nico.h@gmx.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/35561 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Mario Limonciello <superm1@gmail.com> Reviewed-by: Richard Hughes <hughsient@gmail.com> Reviewed-by: David Hendricks <david.hendricks@gmail.com> Reviewed-by: Angel Pons <th3fanbus@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d1f663fb1..b63875e23 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('flashromutils', 'c',
- version : '1.0',
+ version : run_command('util/getversion.sh', '-v').stdout().strip(),
license : 'GPL-2.0',
meson_version : '>=0.47.0',
default_options : ['warning_level=2', 'c_std=c99'],