summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMiklós Márton <martonmiklosqdev@gmail.com>2019-08-01 19:14:10 +0200
committerNico Huber <nico.h@gmx.de>2019-12-31 17:25:41 +0000
commit324929c3d725ce264b2390525dbc9070f6029cc4 (patch)
tree73ee656c8bc1933329e4239214e4b0eaaadb36f8 /meson.build
parent728062f7ff7c2dca31bc99fe45eb5cacd7cf2d53 (diff)
downloadflashrom-324929c3d725ce264b2390525dbc9070f6029cc4.tar.gz
flashrom-324929c3d725ce264b2390525dbc9070f6029cc4.tar.bz2
flashrom-324929c3d725ce264b2390525dbc9070f6029cc4.zip
Add support for STLINK V3 debugger/programmer via its SPI bridge
Change-Id: Icffab87ac8f2c570187ed753ec70f054541873a4 Signed-off-by: Miklós Márton <martonmiklosqdev@gmail.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/34661 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b63875e23..375089c30 100644
--- a/meson.build
+++ b/meson.build
@@ -61,6 +61,7 @@ config_satamv = get_option('config_satamv')
config_satasii = get_option('config_satasii')
config_serprog = get_option('config_serprog')
config_usbblaster_spi = get_option('config_usbblaster_spi')
+config_stlinkv3_spi = get_option('config_stlinkv3_spi')
cargs = []
deps = []
@@ -271,6 +272,10 @@ if config_usbblaster_spi
srcs += 'usbblaster_spi.c'
cargs += '-DCONFIG_USBBLASTER_SPI=1'
endif
+if config_stlinkv3_spi
+ srcs += 'stlinkv3_spi.c'
+ cargs += '-DCONFIG_STLINKV3_SPI=1'
+endif
# bitbanging SPI infrastructure
if config_bitbang_spi