summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2022-04-26 14:53:18 +1000
committerAnastasia Klimchuk <aklm@chromium.org>2022-04-29 05:40:08 +0000
commitb899ab233fc3e49386bfa5b4f88901aafe4d066e (patch)
tree82572e60f012b84852b1463065386a77f1ee6835 /meson.build
parent2289578807feec8a978d81bbab92615aae76852f (diff)
downloadflashrom-b899ab233fc3e49386bfa5b4f88901aafe4d066e.tar.gz
flashrom-b899ab233fc3e49386bfa5b4f88901aafe4d066e.tar.bz2
flashrom-b899ab233fc3e49386bfa5b4f88901aafe4d066e.zip
meson: Treat warnings as errors
Makefile treats warnings as errors, so enable the same option for meson. Makefile has an option to disable "warnings as errors" option from command line. The same can be achieved with meson, see scenario 2 below. TEST=I verified the following scenarious 1) check that warnings treated as errors by enforcing higher warning level `meson setup --warnlevel=3 --wipe` `ninja test` shows tons of errors because warning level 3 is pedantic, build fails 2) disable "warning as errors" option from command line `meson configure -Dwerror=false` `ninja test` Now all warnings are non-blocking for build, so tests pass 3) back home `meson configure -Dwerror=true` `meson setup --warnlevel=2 --wipe` `ninja test` No warnings and tests pass 4) defaults: create new directory and run meson will all default options No warnings, all tests pass. Change-Id: I06c72abf1c861f9b35736e02ef7f4a4fb6909b97 Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/63852 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Thomas Heijligen <src@posteo.de> Reviewed-by: Peter Marheine <pmarheine@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 80ccfb38e..222f7c151 100644
--- a/meson.build
+++ b/meson.build
@@ -5,6 +5,7 @@ project('flashromutils', 'c',
default_options : [
'warning_level=2',
'c_std=c99',
+ 'werror=true',
'optimization=s',
'debug=false'],
)