summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Goncharov <chat@joursoir.net>2022-09-09 09:53:29 +0300
committerAnastasia Klimchuk <aklm@chromium.org>2022-11-29 21:05:00 +0000
commitd0fc4e76e16b6c413519fcfaba9f382afd080407 (patch)
tree0005e4e5e95e29cc9b0450464cc13ff564a77735 /meson.build
parent224ce8168791c5914e4289d700ae15f3f9926c8d (diff)
downloadflashrom-d0fc4e76e16b6c413519fcfaba9f382afd080407.tar.gz
flashrom-d0fc4e76e16b6c413519fcfaba9f382afd080407.tar.bz2
flashrom-d0fc4e76e16b6c413519fcfaba9f382afd080407.zip
tests: add basic lifecycle test for ch341a_spi
TEST=the following scenarios run tests successfully 1) ch341a_spi is enabled result: all tests run and pass, including ch341a 2) ch341a_spi is disabled result: ch341a_spi test is skipped, the rest of tests run and pass 3) libusb isn't presented in the system result: tests for usb programmers are skipped, the rest of tests run normally Change-Id: If28fbe09ad685082152aa3a7e8d5a150169aee9e Signed-off-by: Alexander Goncharov <chat@joursoir.net> Reviewed-on: https://review.coreboot.org/c/flashrom/+/67664 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d4a8ad174..14a84acdf 100644
--- a/meson.build
+++ b/meson.build
@@ -182,6 +182,7 @@ programmer = {
'deps' : [ libusb1 ],
'groups' : [ group_usb, group_external ],
'srcs' : files('ch341a_spi.c'),
+ 'test_srcs' : files('tests/ch341a_spi.c'),
'flags' : [ '-DCONFIG_CH341A_SPI=1' ],
},
'dediprog' : {