summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorVictor Ding <victording@google.com>2021-07-21 17:37:12 +1000
committerNico Huber <nico.h@gmx.de>2021-09-22 13:22:21 +0000
commite3f55a13ba256bf643aa47084db16a98c3fe60e6 (patch)
treea39e1c8324c10fe861243331391607f034640aad /meson.build
parentbbe9a77343952e50015468dfc67f141f5ed4a4a3 (diff)
downloadflashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.tar.gz
flashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.tar.bz2
flashrom-e3f55a13ba256bf643aa47084db16a98c3fe60e6.zip
ene_lpc: remove ENE LPC programmer
Best efforts were made to upstream older Chromebook support for good intentions for folks interested. However, we no longer have the hardware available to test and maintain the code as the hardware is now end of life. Therefore the code state has sadly fallen into a unknown state. BUG=none BRANCH=none TEST=builds and ninja test passes Signed-off-by: Victor Ding <victording@google.com> Change-Id: I3f40db22c42c04ce029c4defd837e05ebb550c9b Reviewed-on: https://review.coreboot.org/c/flashrom/+/56475 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 6ebf3dcd0..f08ec240e 100644
--- a/meson.build
+++ b/meson.build
@@ -41,7 +41,6 @@ config_digilent_spi = get_option('config_digilent_spi')
config_jlink_spi = get_option('config_jlink_spi')
config_drkaiser = get_option('config_drkaiser')
config_dummy = get_option('config_dummy')
-config_ene_lpc = get_option('config_ene_lpc')
config_ft2232_spi = get_option('config_ft2232_spi')
config_gfxnvidia = get_option('config_gfxnvidia')
config_raiden_debug_spi = get_option('config_raiden_debug_spi')
@@ -213,10 +212,6 @@ if config_internal
cargs += '-DCONFIG_INTERNAL_DMI=1'
endif
endif
-if config_ene_lpc
- srcs += 'ene_lpc.c'
- cargs += '-DCONFIG_ENE_LPC=1'
-endif
if config_it8212
srcs += 'it8212.c'
cargs += '-DCONFIG_IT8212=1'