summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-10-15 16:24:51 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2021-11-08 03:52:36 +0000
commit8aaee03333194b29683d23bcb3ac56ea74b11007 (patch)
tree6a14d7570c2dff74c41614c0b9512f12cc52580d /tests/meson.build
parent4ab9bd7ffbc8dada52a89ab0508d60a06547ac89 (diff)
downloadflashrom-8aaee03333194b29683d23bcb3ac56ea74b11007.tar.gz
flashrom-8aaee03333194b29683d23bcb3ac56ea74b11007.tar.bz2
flashrom-8aaee03333194b29683d23bcb3ac56ea74b11007.zip
tests: Add tests to write on chip
This patch adds two tests and initialises page_size in mock chip chip_W25Q128_V. page_size was not needed for previous tests (erase and read). page_size only needed to execute writing on chip with dummyflasher, so it is added here. BUG=b:181803212 TEST=ninja test Change-Id: I6f0336613ab16a7e59857006496e3590ddb14d00 Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58357 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 30b1e782e..ebfbaefad 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -41,6 +41,7 @@ mocks = [
'-Wl,--wrap=write',
'-Wl,--wrap=fopen',
'-Wl,--wrap=fopen64',
+ '-Wl,--wrap=fdopen',
'-Wl,--wrap=fwrite',
'-Wl,--wrap=fflush',
'-Wl,--wrap=stat',