summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAnastasia Klimchuk <aklm@chromium.org>2021-08-02 13:58:59 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2021-08-19 04:30:13 +0000
commited43237cfa71d4867eaf966ec1fcef79778595fb (patch)
treeef03530dfb4ea8d747d229f1dac66e2eae927c63 /tests/meson.build
parentcdf8cf4afe305b10bc6169856282cdbb6bcfbf32 (diff)
downloadflashrom-ed43237cfa71d4867eaf966ec1fcef79778595fb.tar.gz
flashrom-ed43237cfa71d4867eaf966ec1fcef79778595fb.tar.bz2
flashrom-ed43237cfa71d4867eaf966ec1fcef79778595fb.zip
tests: Add tests to erase a chip
Two tests cover the code which performs do_erase operation. First one works with fake chip and dummy programmer. Fake chip has all operations defined, and a buffer to emulate chip memory. Second one uses the chip which is closer to the real one, because read/write/unlock/erase operations are real. The tests takes the advantage of dummyflasher's capability of emulating a W25Q128.V chip. BUG=b:181803212 TEST=builds and ninja test Change-Id: I6f74bfe4e02244d24d6c837cc3d551251e7b4898 Signed-off-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/56501 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 2bde3f01a..63fec5aa6 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -20,6 +20,7 @@ srcs = [
'spi25.c',
'init_shutdown.c',
'layout.c',
+ 'chip.c',
]
mocks = [