summaryrefslogtreecommitdiffstats
path: root/util/flashrom_tester/Cargo.toml
diff options
context:
space:
mode:
authorEdward O'Callaghan <quasisec@google.com>2020-02-18 14:38:08 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2020-02-24 09:15:00 +0000
commit0f510a7458e0efe95534667bba122b4ab67b26c1 (patch)
tree19032bf855ce51d207b494e1c0ed54e7642c69a7 /util/flashrom_tester/Cargo.toml
parent7a7fee1695bc3ea9df4a9a058a1805210328d691 (diff)
downloadflashrom-0f510a7458e0efe95534667bba122b4ab67b26c1.tar.gz
flashrom-0f510a7458e0efe95534667bba122b4ab67b26c1.tar.bz2
flashrom-0f510a7458e0efe95534667bba122b4ab67b26c1.zip
util/flashrom_tester: Upstream E2E testing framework
The following is a E2E tester for a specific chip/chipset combo. The tester itself is completely self-contained and allows the user to specify which tests they wish to preform. Supported tests include: - chip-name - read - write - erase - wp-locking Change-Id: Ic2905a76cad90b1546b9328d668bf8abbf8aed44 Signed-off-by: Edward O'Callaghan <quasisec@google.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/38951 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: David Hendricks <david.hendricks@gmail.com>
Diffstat (limited to 'util/flashrom_tester/Cargo.toml')
-rw-r--r--util/flashrom_tester/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/util/flashrom_tester/Cargo.toml b/util/flashrom_tester/Cargo.toml
new file mode 100644
index 000000000..50f2c4a7d
--- /dev/null
+++ b/util/flashrom_tester/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "flashrom_tester"
+version = "1.6.0"
+authors = ["Edward O'Callaghan <quasisec@chromium.org>",
+ "Peter Marheine <pmarheine@chromium.org>"]
+edition = "2018"
+build = "build.rs"
+
+[lib]
+name = "flashrom_tester"
+
+[[bin]]
+name = "flashrom_tester"
+required-features = ["cli"]
+
+[dependencies]
+built = { version = "0.3", default-features = false, features = ["serialized_time", "serialized_version"] }
+chrono = { version = "0.4", optional = true }
+clap = { version = "2.33", default-features = false, optional = true }
+flashrom = { path = "flashrom/" }
+log = { version = "0.4", features = ["std"] }
+rand = "0.6.4"
+serde_json = "1"
+sys-info = "0.5.7"
+
+[build-dependencies]
+built = { version = "0.3", default-features = false, features = ["serialized_time", "serialized_version"] }
+
+[features]
+# Features required to build the CLI binary but not the library
+cli = ["chrono", "clap"]
+default = ["cli"]