summaryrefslogtreecommitdiffstats
path: root/util/flashrom_tester/flashrom/Cargo.toml
diff options
context:
space:
mode:
authorEvan Benn <evanbenn@chromium.org>2022-06-01 12:45:01 +1000
committerEdward O'Callaghan <quasisec@chromium.org>2022-08-26 05:07:09 +0000
commitf6d9a2847e6b66a8f1415e04dc2bd13cc1d7e555 (patch)
tree857f5cd26ecdd05007114228d95284031fca4bd4 /util/flashrom_tester/flashrom/Cargo.toml
parentb41bb5622c08edb33cd83aa05973513db3869af0 (diff)
downloadflashrom-f6d9a2847e6b66a8f1415e04dc2bd13cc1d7e555.tar.gz
flashrom-f6d9a2847e6b66a8f1415e04dc2bd13cc1d7e555.tar.bz2
flashrom-f6d9a2847e6b66a8f1415e04dc2bd13cc1d7e555.zip
flashrom_tester: Add an implementation using libflashrom
flashrom_tester 'flashrom' crate was implemented using the flashrom commandline. Add a second implementation using the libflashrom interface via the libflashrom and libflashrom-sys rust bindings. BUG=b:230545739 BRANCH=None TEST=cargo test TEST=on grunt (AMD) TEST=/usr/bin/flashrom_tester --libflashrom host TEST=/usr/bin/flashrom_tester --flashrom_binary /usr/sbin/flashrom host Change-Id: Ic4db6c829d7e8dc707a10c10e1ca0d9b8abccdec Signed-off-by: Evan Benn <evanbenn@chromium.org> Reviewed-on: https://review.coreboot.org/c/flashrom/+/65282 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'util/flashrom_tester/flashrom/Cargo.toml')
-rw-r--r--util/flashrom_tester/flashrom/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/util/flashrom_tester/flashrom/Cargo.toml b/util/flashrom_tester/flashrom/Cargo.toml
index 27216cbde..a2447d04f 100644
--- a/util/flashrom_tester/flashrom/Cargo.toml
+++ b/util/flashrom_tester/flashrom/Cargo.toml
@@ -6,4 +6,5 @@ authors = ["Edward O'Callaghan <quasisec@chromium.org>",
edition = "2018"
[dependencies]
-log = "0.4" \ No newline at end of file
+log = "0.4"
+libflashrom = { path = "../../../bindings/rust/libflashrom" }