summaryrefslogtreecommitdiffstats
path: root/util/shell.nix
diff options
context:
space:
mode:
authorFelix Singer <felix.singer@secunet.com>2021-09-28 15:20:17 +0200
committerNico Huber <nico.h@gmx.de>2021-10-10 16:02:10 +0000
commit29418b74796da22445b51591a604ee6ebc8d8b70 (patch)
tree6eec9df07c613eb6c9ad5f41b0767f10b9e1dc1b /util/shell.nix
parenta2d09ca893edd4519a733f29c22a45c0a9a3efe3 (diff)
downloadflashrom-29418b74796da22445b51591a604ee6ebc8d8b70.tar.gz
flashrom-29418b74796da22445b51591a604ee6ebc8d8b70.tar.bz2
flashrom-29418b74796da22445b51591a604ee6ebc8d8b70.zip
util: Add Nix shell file
Add a Nix shell file which is able to compile flashrom. Change-Id: I9757b952f4b034e98c2b4b70fbede52d8efb9d50 Signed-off-by: Felix Singer <felix.singer@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58012 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'util/shell.nix')
-rw-r--r--util/shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/util/shell.nix b/util/shell.nix
new file mode 100644
index 000000000..d6ddf8177
--- /dev/null
+++ b/util/shell.nix
@@ -0,0 +1,16 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "flashrom";
+
+ buildInputs = [
+ cmocka
+ libftdi1
+# libjaylink # Will be added in NixOS 21.11
+ libusb1
+ meson
+ ninja
+ pciutils
+ pkg-config
+ ];
+}