summaryrefslogtreecommitdiffstats
path: root/bindings/rust/libflashrom-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/rust/libflashrom-sys/Cargo.toml')
-rw-r--r--bindings/rust/libflashrom-sys/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/bindings/rust/libflashrom-sys/Cargo.toml b/bindings/rust/libflashrom-sys/Cargo.toml
new file mode 100644
index 000000000..af84b8af8
--- /dev/null
+++ b/bindings/rust/libflashrom-sys/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "libflashrom-sys"
+version = "0.1.0"
+description = "Native bindings to the libflashrom library."
+readme = "../README"
+homepage = "https://www.flashrom.org/"
+repository = "https://review.coreboot.org/plugins/gitiles/flashrom/"
+license = "GPL-2.0-only"
+categories = ["external-ffi-bindings", "hardware-support"]
+links = "flashrom"
+build = "build.rs"
+edition = "2021"
+
+[build-dependencies]
+pkg-config = "0.3.19"
+bindgen = "0.59.2"