summaryrefslogtreecommitdiffstats
path: root/bindings/rust/libflashrom/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/rust/libflashrom/Cargo.toml')
-rw-r--r--bindings/rust/libflashrom/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/bindings/rust/libflashrom/Cargo.toml b/bindings/rust/libflashrom/Cargo.toml
new file mode 100644
index 000000000..1d8fb5298
--- /dev/null
+++ b/bindings/rust/libflashrom/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "libflashrom"
+version = "0.1.0"
+description = "Bindings to the libflashrom library."
+readme = "../README"
+homepage = "https://www.flashrom.org/"
+repository = "https://review.coreboot.org/plugins/gitiles/flashrom/"
+license = "GPL-2.0-only"
+categories = ["api-bindings", "hardware-support"]
+edition = "2021"
+
+[dependencies]
+libflashrom-sys = { path = "../libflashrom-sys" }
+libc = "0.2.124"
+regex = "1.5.5"
+once_cell = "1.7.2"
+
+[dev-dependencies]
+rusty-fork = "0.3.0"
+gag = "1"
+
+[build-dependencies]
+pkg-config = "0.3.19"
+cc = "1.0.72"