summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3d395e867..5374e8716 100644
--- a/meson.build
+++ b/meson.build
@@ -321,6 +321,7 @@ endif
prefix = get_option('prefix')
sbindir = join_paths(prefix, get_option('sbindir'))
libdir = join_paths(prefix, get_option('libdir'))
+mandir = join_paths(prefix, get_option('mandir'))
install_headers([
'libflashrom.h',
@@ -394,6 +395,16 @@ pkgg.generate(
description : 'library to interact with flashrom',
)
+conf.set('VERSION', version)
+conf.set('MAN_DATE', run_command('util/getrevision.sh', '--date', 'flashrom.8.tmpl').stdout().strip())
+configure_file(
+ input : 'flashrom.8.tmpl',
+ output : 'flashrom.8',
+ configuration : conf,
+ install: true,
+ install_dir: join_paths(mandir, 'man8'),
+)
+
flashrom_dep = declare_dependency(
link_with : flashrom,
include_directories : include_directories('.'),