summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 1923fdfb7..e1b6c1663 100644
--- a/meson.build
+++ b/meson.build
@@ -67,7 +67,6 @@ cargs = []
deps = []
srcs = []
-need_libusb0 = false
need_raw_access = false
need_serial = false
@@ -91,6 +90,7 @@ else
config_dediprog = false
config_digilent_spi = false
config_developerbox_spi = false
+ config_pickit2_spi = false
endif
# some programmers require libpci
@@ -242,7 +242,6 @@ endif
if config_pickit2_spi
srcs += 'pickit2_spi.c'
cargs += '-DCONFIG_PICKIT2_SPI=1'
- need_libusb0 = true
endif
if config_pony_spi
srcs += 'pony_spi.c'
@@ -293,11 +292,6 @@ if need_serial
srcs += 'serial.c'
endif
-# raw deprecated and old USB library
-if need_libusb0
- deps += dependency('libusb')
-endif
-
prefix = get_option('prefix')
sbindir = join_paths(prefix, get_option('sbindir'))
libdir = join_paths(prefix, get_option('libdir'))