summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8bb3e6509..b847c63b3 100644
--- a/meson.build
+++ b/meson.build
@@ -290,6 +290,11 @@ if config_bitbang_spi
cargs += '-DCONFIG_BITBANG_SPI=1'
endif
+if host_machine.system() == 'linux'
+ srcs += 'i2c_helper_linux.c'
+ cargs += '-DCONFIG_I2C_SUPPORT=1'
+endif
+
# raw memory, MSR or PCI port I/O access
if need_raw_access
srcs += 'hwaccess.c'