summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 3 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index d20f24cd4..caeea6e6c 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project('flashromutils', 'c',
version : run_command('util/getversion.sh', '--version', check : true).stdout().strip(),
license : 'GPL-2.0',
- meson_version : '>=0.53.0',
+ meson_version : '>=0.57.0',
default_options : [
'warning_level=2',
'c_std=c99',
@@ -11,6 +11,8 @@ project('flashromutils', 'c',
],
)
+subdir('doc')
+
# libtool versioning
lt_current = '1'
lt_revision = '0'
@@ -621,17 +623,6 @@ pkgg.generate(
description : 'library to interact with flashrom',
)
-config_manfile = configuration_data()
-config_manfile.set('VERSION', version)
-config_manfile.set('MAN_DATE', run_command('util/getversion.sh', '--man-date', check : true).stdout().strip())
-configure_file(
- input : 'flashrom.8.tmpl',
- output : 'flashrom.8',
- configuration : config_manfile,
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man8'),
-)
-
if get_option('classic_cli').auto() or get_option('classic_cli').enabled()
classic_cli = executable(
'flashrom',