summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index b0375a122..66adb92bd 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -69,9 +69,7 @@ mocks = [
'-Wl,--wrap=fsync',
'-Wl,--wrap=fread',
'-Wl,--wrap=fgets',
- '-Wl,--wrap=__fgets_chk',
'-Wl,--wrap=fprintf',
- '-Wl,--wrap=__vfprintf_chk',
'-Wl,--wrap=fclose',
'-Wl,--wrap=feof',
'-Wl,--wrap=ferror',
@@ -115,6 +113,7 @@ flashrom_tests = executable('flashrom_unit_tests',
cargs,
'-ffunction-sections',
'-fdata-sections',
+ '-U_FORTIFY_SOURCE',
],
export_dynamic : true,
link_args : mocks,