summaryrefslogtreecommitdiffstats
path: root/util/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'util/shell.nix')
-rw-r--r--util/shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/util/shell.nix b/util/shell.nix
new file mode 100644
index 000000000..987777c35
--- /dev/null
+++ b/util/shell.nix
@@ -0,0 +1,18 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "flashrom";
+
+ buildInputs = [
+ cmocka
+ gcc
+ gnumake
+ libftdi1
+ libjaylink
+ libusb1
+ meson
+ ninja
+ pciutils
+ pkg-config
+ ];
+}